home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / app-mobilephone / obexftp-0.18 / obexftp-0.18.ebuild < prev    next >
Text File  |  2006-05-08  |  1KB  |  45 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.18.ebuild,v 1.6 2006/03/06 20:36:12 mrness Exp $
  4.  
  5. inherit perl-module flag-o-matic
  6.  
  7. DESCRIPTION="File transfer over OBEX for mobile phones"
  8. SRC_URI="http://triq.net/obexftp/${P}.tar.gz"
  9. HOMEPAGE="http://triq.net/obex"
  10.  
  11. SLOT="0"
  12. LICENSE="GPL-2"
  13. KEYWORDS="~amd64 ~ppc x86"
  14. IUSE="bluetooth debug perl python tcltk"
  15.  
  16. DEPEND="=dev-libs/openobex-1.0*
  17.     bluetooth? ( >=net-wireless/bluez-libs-2.19 )
  18.     perl? ( >=dev-lang/perl-5.8.6 )
  19.     python? ( >=dev-lang/python-2.4.2 )
  20.     tcltk? ( >=dev-lang/tcl-8.4.9 )"
  21.  
  22. src_compile() {
  23.     if use debug ; then
  24.         strip-flags
  25.         append-flags "-g -DOBEXFTP_DEBUG=5"
  26.     fi
  27.  
  28.     econf \
  29.         $(use_enable bluetooth) \
  30.         $(use_enable perl) \
  31.         $(use_enable python) \
  32.         $(use_enable tcltk tcl) || die "econf failed"
  33.     emake || die "emake failed"
  34. }
  35.  
  36. src_install() {
  37.     make DESTDIR=${D} install || die "make install failed"
  38.  
  39.     dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
  40.     dohtml doc/*.html
  41.     insinto /usr/share/doc/${PF}/examples
  42.     doins -r apps/*_example.*
  43.     use perl && fixlocalpod
  44. }
  45.